Added: [HA] [HUB] Show password requirements when a cluster administrator changes password.
Added: A setting to block HTTP requests sent to an unrecognized Host header.
Added: ARC sealing for mailing list messages that keep the poster's address in the From header.
Added: ARC sealing for messages forwarded through aliases to external members.
Added: Blank password guards when creating users.
Added: Domains can now be configured to allow users to opt in to email Classification versus it being enabled for all users of the domain.
Added: System setting to enable/disale the SOAP API endpoints.
Added: The ability to disable volume mounts.
Changed: [HA] [HUB] Improved error page styling.
Changed: [HA] [HUB] Renamed the Settings page to “General”.
Changed: A 2FA code is now required when disabling the feature except for System Administrators.
Changed: Forwarded messages now retain the sender's DKIM signature and are also signed by the forwarding domain, improving delivery of SRS-forwarded mail to major providers.
Changed: The toggles for reporting spam corrections for SpamFoo and Rspamd are now separate controls.
Changed: Updated listed time zones.
Fixed: [HA] [HUB] Login page custom help login is appending a GET string.
Fixed: [HA] [HUB] New IDS rule shows an incorrect error message in text fields.
Fixed: [HA] [HUB] Routing Rules display a GUID in place of a gateway name.
Fixed: [HA] Spam settings are not always syncing to nodes.
Fixed: 2FA ignores webmail's service access setting.
Fixed: A specific GRP file can cause the web interface to hang.
Fixed: A user named after a recently deleted mailing list will not receive emails.
Fixed: Accounts -> Users / Alias / Mailing List, Column and Field Names do not match.
Fixed: Bounce Reason event condition doesn't work as expected.
Fixed: Bounced local recipients miscounted as remote recipients in delivery throttling and stats.
Fixed: Certain European and Asian timezones do not work correctly in calendar events.
Fixed: Chat option shows as available on professional edition.
Fixed: Consistency issues between domain and system level event conditions.
Fixed: Copy pasting files does not always work in Online Meetings.
Fixed: DMARC treats an SPF result of Neutral as a Pass.
Fixed: External HTML images in emails do not display correctly with certain formatting.
Fixed: External posters to Mailing List with "Poster Address" as FROM fail DKIM/SPF checks on remote delivery.
Fixed: Failed Delivery Status Notification (DSN) message is sent when SMTPUTF8 style DSN cannot be delivered.
Fixed: Forwarded messages could arrive with broken DKIM and ARC signatures.
Fixed: Idle email compose windows can sometimes fail to upload files.
Fixed: Meeting invites sent from Outlook [MAPI] using a non-Unicode character encoding can appear incorrectly in attendee calendars.
Fixed: Polish characters do not appear correctly when emails are auto-forwarded from SmarterMail to Microsoft 365.
Fixed: Renaming a folder in Outlook [IMAP] doesn't always sync to webmail.
Fixed: Sending event invites with certain delegate settings can cause a delivery loop.
Fixed: SharePoint sync can stop working when ann account is configured with 2FA.
Fixed: Some contact fields are lost during WebDAV sync.
Fixed: SpamFoo classification still occurs even when it's disabled for a user.
Fixed: Subject prefixes and spam-type indicators (e.g.m SPAM LOW:) are sent to SpamFoo when reporting spam/ham feedback.
Fixed: Using webmail with Firefox browsers overlaps enable/disable toggles on calendars.
Fixed: Webhooks in routing rules, system events, and domain events can accept invalid JSON bodies.
Efficiency: Better message handling when secondary storage is unreachable.
Security: Improved handling of authentication attempts with empty passwords.